メインコンテンツまでスキップ

Seeed Studio XIAO ESP32-S3 シリーズ入門ガイド

Seeed Studio XIAO ESP32-S3Seeed Studio XIAO ESP32-S3 SenseSeeed Studio XIAO ESP32-S3 Plus

はじめに​

Seeed Studio XIAO シリーズは、同様のハードウェア構成を共有する非常に小型の開発ボードで、そのサイズは文字通り親指サイズです。コードネーム「XIAO」は、その特徴の半分である「Tiny(小さい)」を表し、もう半分は「Puissant(強力)」を意味します。

Seeed Studio XIAO ESP32-S3 Sense は、カメラセンサ、デジタルマイク、SD カード対応機能を統合しています。組み込み ML の計算能力と撮影機能を組み合わせることで、この開発ボードはインテリジェントな音声およびビジョン AI を始めるための優れたツールとなります。

ヒント

OV2640 カメラは生産終了となり、その後の XIAO ESP32-S3 Sense では OV3660 カメラモデルが使用されていました。OV3660 の在庫切れに伴い、XIAO ESP32-S3 Sense のカメラは現在、オートフォーカス(AF)機能付きの OV5640 カメラへとアップグレードされています。これは自動フォーカスをサポートする高解像度モジュールです。Wiki のカメラサンプルコードは OV2640、OV3660、OV5640 に対応しており、OV5640 用のサンプルには AF サポートが組み込まれています(OV3660 と OV2640 には AF ハードウェアがなく、固定フォーカスで動作します)。このカメラモジュール移行期間中は、OV5640 または OV3660 のいずれかを搭載したボードが出荷される可能性がありますが、Wiki のサンプルコードは両方をサポートするように調整されているため、どちらのモジュールでも使用に影響なく動作します。

仕様​

製品XIAO ESP32-S3XIAO ESP32-S3 SenseXIAO ESP32-S3 Plus
プロセッサESP32-S3R8
Xtensa LX7 デュアルコア 32-bit プロセッサ、最大 240 MHz 動作
無線完全な 2.4GHz Wi-Fi サブシステム
Bluetooth Low Energy 5.0 / Bluetooth Mesh
内蔵センサ/1x OV5640 カメラセンサ(オートフォーカス付き)
1x デジタルマイク
/
メモリオンチップ 8MB PSRAM & 8MB Flashオンチップ 8MB PSRAM & 8MB Flash
オンボード SD カードスロット(32GB FAT 対応)
オンチップ 8MB PSRAM & 16MB Flash
インターフェース1x UART
1x IIC
1x SPI
11x GPIO(PWM)
9x ADC
1x User LED
1x Charge LED
1x Reset ボタン
1x Boot ボタン
1x UART
1x IIC
1x IIS
1x SPI
11x GPIOs (PWM)
9x ADC
1x User LED
1x Charge LED
1x B2B コネクタ(追加 GPIO×2)
1x Reset ボタン
1x Boot ボタン
2x UART
1x IIC
1x IIS
2x SPI
18x GPIOs (PWM)
9x ADC
1x User LED
1x Charge LED
1x B2B コネクタ
1x Reset ボタン
1x Boot ボタン
寸法21 x 17.8mm21 x 17.8 x 15mm(拡張ボード付き)21 x 17.8mm
電源(Typ.)入力電圧(Type-C):5V
入力電圧(BAT):3.7V
消費電力回路動作電圧:
- Type-C: 5V@19mA
- BAT: 3.8V@22mA
回路動作電圧:
- Type-C: 5V@38.3mA
- BAT: 3.8V@43.2mA (with expansion board)
回路動作電圧:
- Type-C: 5V@28mA
- BAT: 3.8V@35mA
/Webcam Web アプリケーション:
- Type-C:
-- 平均消費電力: 5V/~140mA
-- 最大消費電力(画像キャプチャ時): 5V/~347mA
- バッテリ:
-- 平均消費電力: 3.8V/~155mA
-- 最大消費電力(画像キャプチャ時): 3.8V/~366mA
/
/マイク録音 & SD カード書き込み:
- Type-C:
-- 平均消費電力: 5V/54.58mA
-- 最大消費電力: 5V/86.7mA
- バッテリ:
-- 平均消費電力: 3.8V/64.5mA
-- 最大消費電力: 3.8V/109.3mA
/
50mA(急速) / 3.8mA(トリクル)/充電電流:
100mA(急速) / 0.9mA(トリクル)
低消費電力モード(Typ.)
(供給電源: 3.8V)
Modem-sleep モード: 27mA
Light-sleep モード: 2mA
Deep Sleep モード: 14μA
Modem-sleep モード: 44mA
Light-sleep モード: 5mA
Deep Sleep モード: 3mA
Modem-sleep モード: 3.8V/31.6 mA
Light-sleep モード: 3.8V/2.45 mA
Deep Sleep モード: 3.8V/33.51 μA
Wi-Fi 有効時消費電力(Typ.)Active モード: 100 mAActive モード: 110 mA(拡張ボード付き)Active モード: 81 mA
BLE 有効時消費電力(Typ.)Active モード: 85 mAActive モード: 102 mA(拡張ボード付き)Active モード: 101 mA
動作温度-20°C ~ 65°C

特長​

  • 高性能 MCU ボード: 最大 240 MHz で動作する ESP32S3 32-bit デュアルコア Xtensa プロセッサチップを搭載し、複数の開発ポートを備え、Arduino / MicroPython をサポート
  • 高度な機能(Sense 向け): 2592x1944 解像度に対応したオートフォーカス付きの着脱可能な OV5640 カメラセンサ(2048x1536 対応の OV3660 カメラセンサおよび 1600x1200 対応の OV2640 カメラセンサとも互換)、さらにデジタルマイクを統合
  • 入念な電源設計: リチウムバッテリ充電管理機能を備え、4 種類の電力消費モードを提供し、最小 14μA の Deep Sleep モードを実現
  • 多彩な可能性を広げる大容量メモリ: 8MB PSRAM と 8MB FLASH(Plus バージョンでは 16MB)を搭載し、外部 32GB FAT メモリ用 SD カードスロットをサポート(XIAO ESP32-S3 のみ)
  • 優れた RF 性能: 2.4GHz Wi-Fi と BLE のデュアル無線通信をサポートし、U.FL アンテナ接続時には 100m 以上の遠距離通信をサポート
  • 親指サイズのコンパクト設計: 21 x 17.8mm のサイズで、XIAO のクラシックなフォームファクタを採用し、ウェアラブルデバイスのようなスペース制約のあるプロジェクトに最適
項目OV5640 カメラ(AF 付き)OV3660 カメラOV2640 カメラ
最大消費電力(640*480)Active モード: ~ TBDActive モード: ~ 0.6AActive モード: ~ 0.65A
平均消費電力(640*480)Active モード: ~ TBDActive モード: ~ 0.12AActive モード: ~ 0.24A
最小消費電力(640*480)Active モード: ~ TBDActive モード: ~ 0.12AActive モード: ~ 0.15A

ハードウェア概要​

始める前に、この製品の基本的なパラメータを把握しておくことが非常に重要です。次の表は、Seeed Studio XIAO ESP32-S3 の特性に関する情報を示しています。

XIAO ESP32-S3 表面​

XIAO ESP32-S3 裏面​

ピンマップ

XIAO ピン機能チップピン代替機能説明
5VVBUS電源入力/出力
GND
3V33V3_OUT電源出力
D0AnalogGPIO1TOUCH1GPIO, ADC
D1AnalogGPIO2TOUCH2GPIO, ADC
D2AnalogGPIO3TOUCH3GPIO, ADC
D3AnalogGPIO4TOUCH4GPIO, ADC
D4Analog, SDAGPIO5TOUCH5GPIO, I2C データ, ADC
D5Analog, SCLGPIO6TOUCH6GPIO, I2C クロック, ADC
D6TXGPIO43GPIO, UART 送信
D7RXGPIO44GPIO, UART 受信
D8Analog, SCKGPIO7TOUCH7GPIO, SPI クロック, ADC
D9Analog, MISOGPIO8TOUCH8GPIO, SPI データ, ADC
D10Analog, MOSIGPIO9TOUCH9GPIO, SPI データ, ADC
D11AnalogGPIO42TOUCH12GPIO, ADC
D12AnalogGPIO41TOUCH13GPIO, ADC
MTDOGPIO40JTAG
MTDIGPIO41JTAG, ADC
MTCKGPIO39JTAG, ADC
MTMSGPIO42JTAG, ADC
ResetCHIP_PU
BootGPIO0ブートモードに入る
U.FL-R-SMT1LNA_INUFL アンテナ
CHARGE_LEDCHG-LED
USER_LEDGPIO21ユーザー用 LED
注意
  • XIAO ESP32-S3 は GPIO41 と GPIO42 をピン A11 と A12 に割り当てていますが、ESP32-S3 チップの特性上、ピン A11 と A12 は ADC 機能をサポートしません。必ずそれらを区別して使用してください。

  • XIAO ESP32-S3 Plus の B2B コネクタは Wio-SX1262 extension board とは互換性がありますが、プラグイン式カメラセンサーボードとは互換性がありません。

電源ピン​

  • 5V - これは USB ポートからの 5V 出力です。これを電圧入力として使用することもできますが、外部電源とこのピンの間には必ず何らかのダイオード(ショットキー、信号用、電力用)を、アノードをバッテリー側、カソードを 5V ピン側にして接続する必要があります。
  • 3V3 - これはオンボードレギュレータからの安定化出力です。700mA まで取り出すことができます。
  • GND - 電源/データ/信号グラウンド

ストラップピン​

各起動時またはリセット時に、チップはいくつかの初期設定パラメータ(どのブートモードでチップを起動するか、フラッシュメモリの電圧など)を必要とします。これらのパラメータはストラップピンを介して渡されます。リセット後、ストラップピンは通常の IO ピンとして動作します。

チップリセット時に、指定されたストラップピンによって制御されるパラメータは次のとおりです。

  • チップのブートモード – GPIO0 および GPIO46
  • VDD_SPI 電圧 – GPIO45
  • ROM メッセージ出力 – GPIO46
  • JTAG 信号ソース – GPIO3

GPIO0、GPIO45、および GPIO46 は、チップリセット時にチップ内部の弱いプルアップ/プルダウン抵抗に接続されています。 これらの抵抗によってストラップピンのデフォルトのビット値が決まります。また、ストラップピンが外部の高インピーダンス回路に接続されている場合も、これらの抵抗によってビット値が決まります。

ビット値を変更するには、ストラップピンを外部のプルダウン/プルアップ抵抗に接続する必要があります。ESP32-S3 をホスト MCU によるデバイスとして使用する場合、ストラップピンの電圧レベルはホスト MCU によって制御することもできます。

すべてのストラップピンにはラッチがあります。システムリセット時に、ラッチはそれぞれのストラップピンのビット値をサンプリングし、チップの電源が切れるかシャットダウンされるまで保持します。ラッチの状態は他の方法で変更することはできません。これにより、ストラップピンの値はチップの動作全体を通して利用可能となり、リセット後はピンを通常の IO ピンとして自由に使用できます。

ストラップピンのタイミング要件に関しては、セットアップ時間やホールド時間といったパラメータがあります。

入門ガイド​

XIAO ESP32-S3 をすばやく使い始められるように、以下のハードウェアおよびソフトウェアの準備を読んで、XIAO の準備を行ってください。

  1. XIAO ESP32-S3

通常版にプリセットされている工場出荷時プログラムは、タッチピン点灯プログラムです。XIAO に電源を入れ、いくつかのピンに触れると、オレンジ色のユーザーインジケーターが点灯します。

  1. XIAO ESP32-S3 Sense

XIAO ESP32-S3 Sense には、WebCam サンプルプログラムがプリインストールされた状態で出荷されます。パッケージ内のアンテナを適切に取り付けて電源を入れることで、このプログラムを使用できます。詳細については、このプログラムに関する Wiki を参照してください。

注記

2025年6月以降、XIAO ESP32-S3 Sense の工場出荷時ファームウェアでは、次の認証情報を持つデフォルトの AP Wi‑Fi が有効になっています。

  • SSID: XIAO_ESP32S3_Sense
  • Password: seeedstudio

ハードウェアの準備​

ピンヘッダのはんだ付け​

XIAO ESP32-S3 はデフォルトではピンヘッダが取り付けられていない状態で出荷されます。拡張ボードやセンサーに接続できるように、自分でピンヘッダを用意し、XIAO の対応するピンにはんだ付けする必要があります。

XIAO ESP32-S3 は非常に小型であるため、ピンヘッダをはんだ付けする際は、異なるピン同士をくっつけないこと、シールドや他の部品に半田を付けないことに注意してください。そうしないと、XIAO が短絡したり正常に動作しなくなる可能性があり、その結果生じた問題はユーザーの責任となります。

アンテナの取り付け​

XIAO ESP32-S3 前面の左下には、独立した「WiFi/BT Antenna Connector」があります。より良い WiFi/Bluetooth 信号を得るために、パッケージ内のアンテナを取り出し、このコネクタに取り付ける必要があります。

アンテナの取り付けにはちょっとしたコツがあります。いきなり強く押し込もうとすると、なかなかはまらず、指も痛くなってしまいます。正しい取り付け方は、まずアンテナコネクタの片側をコネクタブロックに差し込み、もう片側を少し押し下げるようにすると、アンテナがカチッとはまります。

アンテナを取り外すときも同様で、力任せに真っ直ぐ引き抜かないでください。片側から持ち上げるように力をかけると、アンテナは簡単に外れます。

拡張ボードの取り付け(Sense 用)​

XIAO ESP32-S3 Sense を購入した場合は、拡張ボードも同梱されているはずです。この拡張ボードには、オートフォーカス付き 2592x1944 OV5640 カメラセンサー(2048x1536 OV3660/1600x1200 OV2640 カメラセンサー版もあり)、オンボード SD カードスロット、およびデジタルマイクが搭載されています。

XIAO ESP32-S3 Sense に拡張ボードを取り付けることで、拡張ボード上の各種機能を使用できます。

拡張ボードの取り付けはとても簡単で、拡張ボード上のコネクタを XIAO ESP32-S3 上の B2B コネクタに合わせて、しっかり押し込み、「カチッ」と音がすれば取り付け完了です。

現在、XIAO ESP32-S3 Sense と完全互換の高性能カメラ OV5640 を新たにラインナップしています。これを購入すれば、カメラを交換して使用することができます。

ov5640 の詳細なパラメータ情報が必要な場合は、以下の表を参照してください。

ヒント

Wiki にあるカメラ関連のすべてのプログラムは、OV5640、OV2640、OV3660 のいずれのカメラにも対応しています。

拡張ボードの取り外し​

Sense 拡張ボードを XIAO ESP32-S3 から分離する必要がある場合は、取り付け時と同じく「横方向から」の方法で、手順を逆にして行います。

ステップ 1. 片方の手で XIAO ESP32-S3 をしっかり持ち、もう一方の手で拡張ボードを持ちます。

ステップ 2. ボードのペアの側面からやさしく力を加え、拡張ボードを B2B コネクタからスライドさせて外します。まず一方の端から少しずつ外し、その後コネクタ全体を徐々に解放していきます。

ステップ 3. 拡張ボードが完全に外れたら、平らで静電気対策された面の上に置いてください。

ボードを垂直方向にこじらないでください

拡張ボードを真上または真下に引き抜いたり、2 枚のボードを本のようにねじったり揺すったりしないでください。XIAO と拡張ボードは B2B(board-to-board)コネクタで接続されています。垂直方向にこじると、ピンが曲がったり、コネクタハウジングが割れたり、XIAO 側の B2B ソケットが破損したりするおそれがあります。

常にコネクタと平行な動きになるように、側面から押すかスライドさせることでボードを分離してください。固くて動かないと感じた場合は、角度をもう一度確認し、上方向の力を強めるのではなく、安定した横方向の力を加えるようにしてください。

強化ヒートシンクの取り付け​

アップグレードされたヒートシンクを取り付けることで、XIAO ESP32-S3 Sense の冷却性能を最適化しましょう。この新しい設計は、特にカメラ使用時のような高負荷動作中に、従来モデルで見られた冷却不足を解消するために作られました。元のヒートシンクでは放熱が不十分であるというフィードバックを受け、より効果的なソリューションが開発されました。

クリックして性能比較を見る

テストの結果、アップグレードされたヒートシンクは、元の構成と比べて次のような利点があることが示されました。

テストサンプル背面の最高温度
ヒートシンクなし63.6°C
デュアルヒートシンクあり53.5°C (🔻10°C)

テスト詳細:

  • 環境: 空調の効いた部屋(約 27°C)
  • 温度測定ツール: OMEGA CL3515R 熱電対
  • 測定位置: XIAO ESP32-S3 の背面サーマルパッド
  • テスト用ファームウェア: WebCamera
  • 電源: Type-C 5V
  • 動作時間: 1 時間

主な結果:

  • ヒートシンクを装着したデバイスは 1 時間以上安定して動作し、性能の低下なく最高温度に達しました。
  • WebCamera を SVGA (800x600) モードでテストした際:
    • XIAO ESP32-S3 はスムーズに動作しました。
    • ビデオ出力は滑らかでした。
    • 温度が大幅に低下し、フレーム落ちや切断もなく、信頼性の高い動作が確保されました。

インストールを開始する前に、次のものを用意してください:

  • 選択したヒートシンク(シングルまたはデュアル)
  • 清潔な ESP32S3

作業を始める前に、デバイスの電源を切り、すべての電源から取り外されていることを確認してください。

notice

購入に関する注意: XIAO ESP32-S3 Sense を購入する際、カメラを搭載したモデルのみヒートシンクが付属していることに注意してください。カメラが付属していないバージョンの ESP32S3 をお持ちの場合は、ヒートシンクを別途購入する必要があります。

取り付けのヒント: ヒートシンクを取り付ける際は、ESP32S3 チップ(主な発熱源)の真上にある Thermal PAD を優先的に覆うようにしてください。適切に位置合わせすることで放熱性能が最適化されます。また、BAT ピンはできるだけ塞がないように注意してください。

それでは、インストール手順を始めましょう:

ステップ 1. ヒートシンクの準備: まず、ヒートシンクの保護カバーを取り外し、熱伝導性の接着面を露出させます。これにより、ヒートシンクを ESP32S3 チップにしっかりと取り付ける準備が整います。

ステップ 2. ヒートシンクの取り付け:

この小型でコンパクトなオプションは通常使用には十分で、すべての GPIO ピンへ完全にアクセスできます。

ステップ 3: 最終確認とテスト

取り付け後、ショートの危険がないようにすべてが確実に固定されていることを確認してください。ヒートシンクが正しく位置合わせされ、しっかりと取り付けられているかを確認します。

ソフトウェアの準備​

XIAO ESP32-S3 に推奨される開発ツールは Arduino IDE です。そのためソフトウェアの準備として、Arduino のインストールを完了する必要があります。

ヒント

初めて Arduino を使用する場合は、Getting Started with Arduino を参照することを強くお勧めします。

  • ステップ 1. お使いのオペレーティングシステムに応じて、安定版の Arduino IDE をダウンロードしてインストールします。
  • ステップ 2. Arduino アプリケーションを起動します。

  • ステップ 3. Arduino IDE に ESP32 ボードパッケージを追加します。

File > Preferences に移動し、"Additional Boards Manager URLs" に以下の URL を入力します:

https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json

Tools > Board > Boards Manager... に移動し、検索ボックスにキーワード esp32 を入力し、最新バージョンの esp32 を選択してインストールします。

注意

XIAO ESP32-S3 用のオンボードパッケージは、バージョン 2.0.8 以上が必要です。

  • ステップ 4. ボードとポートを選択します。

Arduino IDE の上部で、ポートを直接選択できます。通常は COM3 以降になります(COM1 と COM2 は通常、ハードウェアシリアルポート用に予約されています)。

また、左側の開発ボード欄で xiao を検索し、XIAO_ESP32S3 を選択します。

これで準備が整い、XIAO ESP32-S3 向けのプログラムを作成してコンパイルおよび書き込みを行うことができます。

BootLoader モード​

誤ったプログラムを使用すると、XIAO のポートが認識されなくなったり、正しく動作しなくなる場合があります。よくある問題としては次のようなものがあります:

  • XIAO をコンピュータに接続しても、ポート番号 が見つからない。
  • XIAO は接続されてポート番号も表示されるが、プログラムの書き込みに失敗する。

上記の 2 つの状況に遭遇した場合、XIAO を BootLoader モードにすることで、認識されないデバイスや書き込み失敗の問題のほとんどを解決できます。具体的な方法は次のとおりです:

  • ステップ 1. XIAO ESP32-S3 上の BOOT ボタンを押したままにします。
  • ステップ 2. BOOT ボタンを押し続けたまま、データケーブルでコンピュータに接続します。コンピュータに接続されたら BOOT ボタンを離します。
  • ステップ 3. File > Examples > 01.Basics > Blink プログラムをアップロードして、XIAO ESP32-S3 の動作を確認します。

リセット​

プログラムが異常に動作した場合、電源投入中に Reset を一度押すことで、XIAO にアップロード済みのプログラムを再実行させることができます。

電源投入中に BOOT キーを押し続け、その後 Reset キーを一度押すと、BootLoader モードに入ることもできます。

ここまでで、XIAO ESP32-S3 の機能とハードウェアについて十分理解できたと思います。次に、最も簡単な Blink プログラムを例にして、XIAO ESP32-S3 で最初の点滅を行ってみましょう!

  • ステップ 1. Arduino アプリケーションを起動します。
  • ステップ 2. File > Examples > 01.Basics > Blink に移動し、プログラムを開きます。
  • ステップ 3. ボードの種類を XIAO ESP32-S3 に選択し、正しいポート番号を選択してプログラムをアップロードします。

プログラムが正常にアップロードされると、次のような出力メッセージが表示され、XIAO ESP32-S3 の右側にあるオレンジ色の LED が点滅しているのを確認できます。

おめでとうございます。これで XIAO ESP32-S3 用のプログラムの作成とアップロード方法を習得しました!

注記

XIAO ESP32-S3 上のユーザー LED ピンが High レベルに設定されているときのみ LED は消灯し、ピンが Low レベルに設定されているときのみ点灯します。

バッテリーの使用​

XIAO ESP32-S3 シリーズには電源管理チップが内蔵されており、バッテリーを使用して XIAO ESP32-S3 に単独で給電したり、XIAO ESP32-S3 の USB ポートからバッテリーを充電したりすることができます。

XIAO にバッテリーを接続したい場合は、認証済みの充電式 3.7V リチウムバッテリーの購入をお勧めします。バッテリーをはんだ付けする際は、必ず正極と負極を区別してください。電源の負極は USB ポートに最も近い側であり、電源の正極は USB ポートから離れた側です。

注記

XIAO ESP32-S3 のすべての GPIO ピンにはそれぞれ固有の機能が割り当てられているため、バッテリーピン用に設定された GPIO はありません。つまり、いずれかの GPIO のアナログ値を読み取ることで、ソフトウェアレベルでバッテリー電圧を取得することはできません。必要であれば、バッテリーの正極と負極を 2 本のピンに接続して、バッテリー電圧を測定することを検討してください。

注意

バッテリー電源を使用している場合、5V ピンには電圧が出力されません。

同時に、バッテリー充電用の赤色インジケーターライトを設計しており、このインジケーターの表示によって、充電中のバッテリーの現在の状態をユーザーに知らせます。

  1. XIAO ESP32-S3 にバッテリーが接続されていない場合、Type-C ケーブルを接続すると赤色のランプが点灯し、30 秒後に消灯します。
  2. バッテリーを接続し、充電のために Type-C ケーブルを接続すると、赤色のランプが点滅します。
  3. Type-C を接続してバッテリーが満充電になると、赤色のランプは消灯します。

UF2 BootLoader​

一部のユーザーは、UF2 ファイルを XIAO に直接書き込んで、プログラムのバッチ書き込みを行いたいと考えていることを理解しています。ここでは、この方法について説明します。

注記

この方法は現在、Windows システムでのみ利用可能です。

ステップ 1: スクリプトのダウンロードと展開

必要なスクリプトの zip ファイルをダウンロードし、ローカルマシンに展開します:

https://files.seeedstudio.com/wiki/SeeedStudio-XIAO-ESP32S3/res/xiaos3-bin2uf2.zip

ステップ 2: BIN ファイルを UF2 ファイルに変換する

Arduino プログラムをコンパイルして保存した後、バイナリ BIN ファイルをエクスポートできます。このファイルは Arduino プロジェクトフォルダ内に生成されます。

先ほど展開した xiaos3-bin2uf2 ディレクトリに BIN ファイルをコピーします。次に、convert_uf2.bat スクリプトを実行して UF2 ファイルを生成します。このとき、bin ファイルの名前が必要になります。

ステップ 3: UF2 BootLoader モードに入る

XIAO をコンピュータに接続し、boot_uf2.bat スクリプトを実行します。XIAO はコンピュータ上で USB ドライブとして表示され、UF2 BootLoader モードに正常に入ったことを示します。

ステップ 4: UF2 ファイルを XIAO ESP32-S3 にコピーする

XIAO ESP32-S3 の USB ドライブにアクセスし、変換した UF2 ファイルをコピーします。コピーが完了すると、XIAO の USB ドライブは自動的に消え、プログラムが起動します。

ヒント
  1. プログラムが正しくコンパイルされ、正常に動作していることを確認してください。そうでない場合、UF2 ファイルは期待どおりに実行されない可能性があります。
  2. Blink 用のサンプル UF2 ファイルが xiaos3-bin2uf2 フォルダ内に用意されています。これをアップロードすると、XIAO ESP32-S3 上のオレンジ色の LED が点滅します。この UF2 ファイルをテストとして使用できます。

ステップ 5: UF2 BootLoader モードに再度入る

別の UF2 ファイルをアップロードするために UF2 BootLoader モードに再度入る必要がある場合は、Reset ボタンを押してから Boot ボタンを素早く押してください。boot_uf2.bat スクリプトを再度実行する必要はありません。

注記

Reset を押してから Boot を素早く押してください!

トラブルシューティング​

Q1: アップロードに失敗する/プログラムが異常に動作する/デバイスポートが見つからない場合はどうすればよいですか?​

上記の問題が発生した場合は、まず XIAO ESP32-S3 のリセットボタンを押して、プログラムを再度実行させてみることをお勧めします。それでも問題が解決しない場合は、プログラムを再確認し、デバイスを復元するために BootLoader Mode で紹介している方法をお読みください。

Q2: 私の XIAO の角が丸い部分でツライチになっていないのはなぜですか?これは品質上の問題ですか?​

まず、これは品質上の問題ではなく、XIAO の通常の機能には影響しないことに注意してください。

XIAO ESP32-S3 は高い集積度を持つため、すべての XIAO の中で最も複雑であり、工場での生産時には PCB をパネル化する必要があります。高集積であるため、パネル基板の接続部は 4 つの丸い角にしか配置できず、その結果、画像のように角の丸みが不均一になる問題が発生します。今後の生産でこの問題が解決されるよう、プロセスの改善に努めてまいります。

Q3: リソースセクションで提供されている XIAO ESP32-S3 用のファクトリーファームウェアをどのように書き込めばよいですか?​

リソースセクションで提供されているスクリプトは Windows をサポートしています。zip ファイルをダウンロードすると、次のファイルが見つかります:

.
├── boot_app0.bin
├── esp32_flasher.py
├── esptool.exe
├── project_config.json
├── xiao_esp32s3_firmware.bin
├── xiao_esp32s3_firmware.bootloader.bin
├── xiao_esp32s3_firmware.partitions.bin
└── xiao_esp32s3_firmware_win.bat

ファームウェアを書き込むには、対応する .bat ファイルを実行するだけです。書き込みに失敗した場合は、プロンプトに表示されるコマンドラインをコピーし、ファイルが存在するディレクトリでターミナルから手動で実行してください。

リソース​

Seeed Studio XIAO ESP32-S3 用​

ハードウェア設計

機械設計

ソフトウェア & ツール

Seeed Studio XIAO ESP32-S3 Sense 用​

ハードウェア設計

機械設計

ソフトウェア & ツール

Seeed Studio XIAO ESP32-S3 Plus 用​

ハードウェア設計

機械設計

Seeed Studio XIAO ESP32-S3 Sense Camera 用​

ハードウェア設計

コースリソース​

その他​

残りのオープンソース資料は現在編集中です。続報をお待ちください!

技術サポート & 製品ディスカッション​

弊社製品をお選びいただきありがとうございます。弊社は、製品をできるだけスムーズにご利用いただけるよう、さまざまなサポートを提供しています。お好みやニーズに合わせて選べる複数のコミュニケーションチャネルをご用意しています。

Loading Comments...